NAME
named-xfer - ancillary agent for inbound zone transfers SYNOPSIS
named-xfer -z zone_to_transfer -f db_file -s serial_no [unrenderable node] [-l debug_log_file [-i ixfr_file [unrenderable node] [-p port# [-S nameserver [__axfr__ DESCRIPTION
Named-xfer is an ancillary program executed by named(8) to perform an inbound zone transfer. It is rarely executed directly, and then only by system administrators who are trying to debug a zone transfer problem. See RFC's 1033, 1034, and 1035 for more information on the Internet name-domain system.
specifies the name of the zone to be transferred.-f db_filespecifies the name of the db_file into which thezone should be dumped when it is received fromthe primary server.-s serial_nospecifies the serial number of our current copyof this zone. If the SOA RR we get from the pri-mary server does not have a serial number higherthan this, the transfer will be aborted.-d debuglevelPrint debugging information. The debuglevel is anumber determines the level of messages printed.-l debug_log_fileSpecifies a log file for debugging messages. Thedefault is system- dependent but is usually in/var/tmp or /usr/tmp. Note that this only applies if ``-d'' is also specified.
Specifies the name of the ixfr_file into which the zone changes from Incremental Zone Transfer (IXFR) should be dumped when it is received from the primary server.
Specifies a trace_file which will contain a pro- tocol trace of the zone transfer. This is proba- bly only of interest to people debugging the name server itself.
Use a different port number. The default is the standard port number as returned by getservbyname(3) for the service ``domain''.
Perform a restricted transfer of only the SOA, NS records and glue A records for the zone. The SOA record will not be loaded by named(8) but will be used to determine when to verify the NS records. See the ``stubs'' directive in named(8) for more information.
Additional arguments are taken as name server addresses in so-called ``dotted-quad syntax only''; no host name are allowed here. At least one address must be specified. Any additional addresses will be tried, in order, if the first one fails to transfer to us successfully. The axfr or ixfr after name server address designates the type of zone trans- fer to perform. Use axfr for a full zone transfer or ixfr for an incremental zone transfer.
SEE ALSO
hostname(7), named(8), resolver(3), resolver(5), RFC 882, RFC 883, RFC 973, RFC 974, RFC 1033, RFC 1034, RFC 1035, RFC 1123, RFC 1995 ``Name Server Operations Guide for BIND''.
4th Berkeley Distribution June 26, 1993 1
One page links to named-xfer(8):