Home
Main website
Display Sidebar
Hide Ads
Recent Changes
View Source:
perlaix(1)
Edit
PageHistory
Diff
Info
LikePages
PERLAIX !!!PERLAIX NAME DESCRIPTION AUTHOR DATE ---- !!NAME README .aix - Perl version 5 on IBM Unix ( AIX ) systems !!DESCRIPTION This document describes various features of IBM 's Unix operating system ( AIX ) that will affect how Perl version 5 (hereafter just Perl) is compiled and/or runs. __Compiling Perl 5 on__ __AIX__ When compiling Perl, you must use an ANSI C compiler. AIX does not ship an ANSI compliant C-compiler with AIX by default, but binary builds of gcc for AIX are widely available. At the moment of writing, AIX supports two different native C compilers, for which you have to pay: __xlc__ and __VAC__ . If you decide to use eiter of these two (which is quite a lot easier than using gcc), be sure to upgrade to the latest available patch level. Currently: xlC.C 3.1.4.0 vac.C 4.4.0.3 (5.0 is already available) Perl can be compiled with either IBM 's ANSI C compiler or with gcc. The former is recommended, as not only can it compile Perl with no difficulty, but also can take advantage of features listed later that require the use of IBM compiler-specific command-line flags. If you decide to use gcc, make sure your installation is recent and complete, and be sure to read the Perl README file for more gcc-specific details. __OS level__ Before installing the patches to the IBM C-compiler you need to know the level of patching for the Operating System. IBM 's command 'oslevel' will show the base, but is not always complete: # oslevel 4.3.0.0 # lslpp -l grep 'bos.rte ' bos.rte 4.3.2.1 COMMITTED Base Operating System Runtime bos.rte 4.3.2.0 COMMITTED Base Operating System Runtime # __Building Dynamic Extensions on__ __AIX__ AIX supports dynamically loadable libraries (shared libraries). Shared libraries end with the suffix .a, which is a bit misleading, because *all* libraries are shared ;-). __The__ __IBM ANSI C Compiler__ All defaults for Configure can be used. If you've chosen to use vac 4, be sure to run 4.4.0.3. Older versions will turn up nasty later on. Here's a brief lead of how to upgrade the compiler to the latest level. Of course this is subject to changes. You can only upgrade versions from ftp-available updates if the first three digit groups are the same (in where you can skip intermediate unlike the patches in the developer snapshots of perl), or to one version up where the `base' is available. In other words, the AIX compiler patches are cumulative. vac.C.4.4.0.1 = # ftp ftp.software.ibm.com Connected to service.boulder.ibm.com. : welcome message ... Name (ftp.software.ibm.com:merijn): anonymous 331 Guest login ok, send your complete e-mail address as password. Password: ... accepted login stuff ftp On AIX 4.2 using xlC, we continue: # lslpp -l fgrep 'xlC.C ' xlC.C 3.1.4.9 COMMITTED C for AIX Compiler xlC.C 3.1.4.0 COMMITTED C for AIX Compiler # grep 'xlC.C.3.1.4.*.bff' xlc.ll -rw-r--r-- 1 45776101 1 6286336 Jul 22 1996 xlC.C.3.1.4.1.bff -rw-rw-r-- 1 45776101 1 6173696 Aug 24 1998 xlC.C.3.1.4.10.bff -rw-r--r-- 1 45776101 1 6319104 Aug 14 1996 xlC.C.3.1.4.2.bff -rw-r--r-- 1 45776101 1 6316032 Oct 21 1996 xlC.C.3.1.4.3.bff -rw-r--r-- 1 45776101 1 6315008 Dec 20 1996 xlC.C.3.1.4.4.bff -rw-rw-r-- 1 45776101 1 6178816 Mar 28 1997 xlC.C.3.1.4.5.bff -rw-rw-r-- 1 45776101 1 6188032 May 22 1997 xlC.C.3.1.4.6.bff -rw-rw-r-- 1 45776101 1 6191104 Sep 5 1997 xlC.C.3.1.4.7.bff -rw-rw-r-- 1 45776101 1 6185984 Jan 13 1998 xlC.C.3.1.4.8.bff -rw-rw-r-- 1 45776101 1 6169600 May 27 1998 xlC.C.3.1.4.9.bff # wget ftp://ftp.software.ibm.com/aix/fixes/v4/xlc/xlC.C.3.1.4.10.bff # On AIX 4.3 using vac, we continue: # lslpp -l fgrep 'vac.C ' vac.C 4.4.0.2 COMMITTED C for AIX Compiler vac.C 4.4.0.0 COMMITTED C for AIX Compiler # grep 'vac.C.4.4.0.*.bff' other.ll -rw-rw-r-- 1 45776101 1 13466624 May 26 1999 vac.C.4.4.0.1.bff -rw-rw-r-- 1 45776101 1 13473792 Aug 31 1999 vac.C.4.4.0.2.bff -rw-rw-r-- 1 45776101 1 13480960 May 19 20:32 vac.C.4.4.0.3.bff # wget ftp://ftp.software.ibm.com/aix/fixes/v4/other/vac.C.4.4.0.3.bff # Then execute the following command, and fill in its choices # smit install_update - Follow the messages ... and you're done. __Using__ __GNU 's gcc for building perl__ ... ? __Using Large Files with Perl__ ... ? __Threaded Perl__ ... ? __64-bit Perl__ ... ? __GDBM and Threads__ ... ? __NFS filesystems and__ ''utime''__(2)__ ... ? !!AUTHOR H.Merijn Brand Structure copied from README .hpux !!DATE Version 0.0.1: 16-10-2000 ----
One page links to
perlaix(1)
:
Man1p
This page is a man page (or other imported legacy content). We are unable to automatically determine the license status of this page.