Penguin
Annotated edit history of perlaix(1) version 1, including all changes. View license author blame.
Rev Author # Line
1 perry 1 PERLAIX
2 !!!PERLAIX
3 NAME
4 DESCRIPTION
5 AUTHOR
6 DATE
7 ----
8 !!NAME
9
10
11 README .aix - Perl version 5 on IBM Unix ( AIX ) systems
12 !!DESCRIPTION
13
14
15 This document describes various features of IBM
16 's Unix operating system ( AIX ) that will
17 affect how Perl version 5 (hereafter just Perl) is compiled
18 and/or runs.
19
20
21 __Compiling Perl 5 on__
22 __AIX__
23
24
25 When compiling Perl, you must use an ANSI C
26 compiler. AIX does not ship an ANSI
27 compliant C-compiler with AIX by default,
28 but binary builds of gcc for AIX are widely
29 available.
30
31
32 At the moment of writing, AIX supports two
33 different native C compilers, for which you have to pay:
34 __xlc__ and __VAC__ . If you decide to use
35 eiter of these two (which is quite a lot easier than using
36 gcc), be sure to upgrade to the latest available patch
37 level. Currently:
38
39
40 xlC.C 3.1.4.0
41 vac.C 4.4.0.3 (5.0 is already available)
42 Perl can be compiled with either IBM 's ANSI C compiler or with gcc. The former is recommended, as not only can it compile Perl with no difficulty, but also can take advantage of features listed later that require the use of IBM compiler-specific command-line flags.
43
44
45 If you decide to use gcc, make sure your installation
46 is recent and complete, and be sure to read the Perl
47 README file for more gcc-specific
48 details.
49
50
51 __OS level__
52
53
54 Before installing the patches to the IBM
55 C-compiler you need to know the level of patching for
56 the Operating System. IBM 's command 'oslevel'
57 will show the base, but is not always
58 complete:
59
60
61 # oslevel
62 4.3.0.0
63 # lslpp -l grep 'bos.rte '
64 bos.rte 4.3.2.1 COMMITTED Base Operating System Runtime
65 bos.rte 4.3.2.0 COMMITTED Base Operating System Runtime
66 #
67
68
69 __Building Dynamic Extensions on__
70 __AIX__
71
72
73 AIX supports dynamically loadable libraries (shared
74 libraries). Shared libraries end with the suffix .a, which
75 is a bit misleading, because *all* libraries are shared
76 ;-).
77
78
79 __The__ __IBM ANSI C
80 Compiler__
81
82
83 All defaults for Configure can be
84 used.
85
86
87 If you've chosen to use vac 4, be sure to run 4.4.0.3.
88 Older versions will turn up nasty later
89 on.
90
91
92 Here's a brief lead of how to upgrade the compiler to
93 the latest level. Of course this is subject to changes. You
94 can only upgrade versions from ftp-available updates if the
95 first three digit groups are the same (in where you can skip
96 intermediate unlike the patches in the developer snapshots
97 of perl), or to one version up where the `base' is
98 available. In other words, the AIX compiler
99 patches are cumulative.
100
101
102 vac.C.4.4.0.1 =
103 # ftp ftp.software.ibm.com
104 Connected to service.boulder.ibm.com.
105 : welcome message ...
106 Name (ftp.software.ibm.com:merijn): anonymous
107 331 Guest login ok, send your complete e-mail address as password.
108 Password:
109 ... accepted login stuff
110 ftp
111 On AIX 4.2 using xlC, we continue:
112
113
114 # lslpp -l fgrep 'xlC.C '
115 xlC.C 3.1.4.9 COMMITTED C for AIX Compiler
116 xlC.C 3.1.4.0 COMMITTED C for AIX Compiler
117 # grep 'xlC.C.3.1.4.*.bff' xlc.ll
118 -rw-r--r-- 1 45776101 1 6286336 Jul 22 1996 xlC.C.3.1.4.1.bff
119 -rw-rw-r-- 1 45776101 1 6173696 Aug 24 1998 xlC.C.3.1.4.10.bff
120 -rw-r--r-- 1 45776101 1 6319104 Aug 14 1996 xlC.C.3.1.4.2.bff
121 -rw-r--r-- 1 45776101 1 6316032 Oct 21 1996 xlC.C.3.1.4.3.bff
122 -rw-r--r-- 1 45776101 1 6315008 Dec 20 1996 xlC.C.3.1.4.4.bff
123 -rw-rw-r-- 1 45776101 1 6178816 Mar 28 1997 xlC.C.3.1.4.5.bff
124 -rw-rw-r-- 1 45776101 1 6188032 May 22 1997 xlC.C.3.1.4.6.bff
125 -rw-rw-r-- 1 45776101 1 6191104 Sep 5 1997 xlC.C.3.1.4.7.bff
126 -rw-rw-r-- 1 45776101 1 6185984 Jan 13 1998 xlC.C.3.1.4.8.bff
127 -rw-rw-r-- 1 45776101 1 6169600 May 27 1998 xlC.C.3.1.4.9.bff
128 # wget ftp://ftp.software.ibm.com/aix/fixes/v4/xlc/xlC.C.3.1.4.10.bff
129 #
130 On AIX 4.3 using vac, we continue:
131
132
133 # lslpp -l fgrep 'vac.C '
134 vac.C 4.4.0.2 COMMITTED C for AIX Compiler
135 vac.C 4.4.0.0 COMMITTED C for AIX Compiler
136 # grep 'vac.C.4.4.0.*.bff' other.ll
137 -rw-rw-r-- 1 45776101 1 13466624 May 26 1999 vac.C.4.4.0.1.bff
138 -rw-rw-r-- 1 45776101 1 13473792 Aug 31 1999 vac.C.4.4.0.2.bff
139 -rw-rw-r-- 1 45776101 1 13480960 May 19 20:32 vac.C.4.4.0.3.bff
140 # wget ftp://ftp.software.ibm.com/aix/fixes/v4/other/vac.C.4.4.0.3.bff
141 #
142 Then execute the following command, and fill in its choices
143
144
145 # smit install_update
146 -
147 Follow the messages ... and you're done.
148
149
150 __Using__ __GNU 's gcc for building
151 perl__
152
153
154 ... ?
155
156
157 __Using Large Files with Perl__
158
159
160 ... ?
161
162
163 __Threaded Perl__
164
165
166 ... ?
167
168
169 __64-bit Perl__
170
171
172 ... ?
173
174
175 __GDBM and Threads__
176
177
178 ... ?
179
180
181 __NFS filesystems and__
182 ''utime''__(2)__
183
184
185 ... ?
186 !!AUTHOR
187
188
189 H.Merijn Brand
190
191
192 Structure copied from README
193 .hpux
194 !!DATE
195
196
197 Version 0.0.1: 16-10-2000
198 ----
This page is a man page (or other imported legacy content). We are unable to automatically determine the license status of this page.